Problems with FreshFlow water fountain? - Cat Forum : Cat Discussion Forums
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 03-02-2005, 12:31 PM Thread Starter
 
Join Date: Jan 2005
Posts: 4
Problems with FreshFlow water fountain?

Has anyone had any problems with their FreshFlow water fountains? I have had one for a little over a month and the pump quit working and it was leaking. I took it back to the petstore to get a replacement because my cats love it so much, but I was wondering what the average life of one of these fountains is?
RachaelR7 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-02-2005, 12:48 PM
Banned
 
Join Date: Nov 2004
Location: Wisconsin, USA
Posts: 12,643
I've had two Fresh Flow fountains for about a month now, and they're working fine. The only complaints would be the ineffectiveness of the filter, and the flow rate drops off quite a bit as the pump gets gunky. In fact, when I clean them (about once a week), it's usually because of poor flow rate, not because the water or fountain are dirty. Oh, and one cat almost chewed through the power cord, so I had to repair that.

What was leaking? And why did the pump quit? Did you ever let it run dry? Did you clean it regularly? Thanks....

edit -> spelling errors & added one question
coaster is offline  
post #3 of 8 (permalink) Old 03-02-2005, 12:50 PM
Cool Cat
 
Join Date: Aug 2004
Location: Atlanta, GA
Posts: 1,072
I've not had any problems. I do, however, clean the fountain at least once every week and a half. I empty the water and take the fountain apart to wipe it all down. During this time, I'll also take the motor apart (directions in manual) to clean all of the hair, food, and grime from it so it doesn't get broken. We've had ours for about 7 months and it still works great. It doesn't take long to clean it all, and I'd rather do that than have it break down on me, you know? I hope your second one works better!
lolakitty23 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 03-02-2005, 02:26 PM
 
Join Date: Jan 2004
Posts: 1,845
I've had mine about a year and a half, maybe two? Can't remember. Still on the same motor. Cleaned every day, so there's no possible gunk buildup.

A common cause of motor failure is that the water level is low, which kills it.
Superkitties is offline  
post #5 of 8 (permalink) Old 03-02-2005, 02:31 PM
Cat Addict
 
Join Date: May 2004
Posts: 1,841
I bought a second one at petsmart. About a week after I had it, Thomas managed to get the lid off and pull the filter out. He then proceeded to eat the filter...or chew holes it in and put all the carbon all over my bedroom. I left it running without a filter, because I didn't have any extra. It ran without the filter for a few days then the moter broke...it was clogged with hair and would no longer run, even after I cleaned.

I guess those filters do more than I thought! Either way, I've never had a problem with my original fountain. Just the one without the filter in it.

I didn't know you could clean the whole motor! Guess I should have read the instructions. Now I'll have to see if I can find them!
Kittys Mom is offline  
post #6 of 8 (permalink) Old 03-02-2005, 03:11 PM
Cool Cat
 
Join Date: Aug 2004
Location: Atlanta, GA
Posts: 1,072
Quote:
Originally Posted by Kitty's Mom
I bought a second one at petsmart. About a week after I had it, Thomas managed to get the lid off and pull the filter out. He then proceeded to eat the filter...or chew holes it in and put all the carbon all over my bedroom. I left it running without a filter, because I didn't have any extra. It ran without the filter for a few days then the moter broke...it was clogged with hair and would no longer run, even after I cleaned.

I guess those filters do more than I thought! Either way, I've never had a problem with my original fountain. Just the one without the filter in it.

I didn't know you could clean the whole motor! Guess I should have read the instructions. Now I'll have to see if I can find them!
We ran out of filters after I threw the last one out, so ours has been running w/o one for about a month now. No worries except for cleaning the motor/pump more often.

Yeah, find those directions! You'll be surprised at how dirty that sucker is!
lolakitty23 is offline  
post #7 of 8 (permalink) Old 03-02-2005, 09:59 PM
Premier Cat
 
Join Date: Jun 2004
Location: Simpsonville, SC
Posts: 3,619
Send a message via AIM to OsnobunnieO
I've had mine for over 6 months... don't know how long exactly. Never had a problem.

I've honestly never used the filter except for the first time I used it. Once I cleaned it, I was disgusted by how grimey the filter was. I usually clean it once a week (when it gets low on water) and haven't had any problems.

I never see hair in it, and every once and a while I see food, but it always just sinks to the bottom and doesn't go through the whole fountain.

I haven't actually cleaned the pump yet, but I'll rinse it with really fast flowing water every now and then... seems to work The only issues I have are when the water gets low, the pump kind of has these little spurts that are rather noisy. Of course it always happens RIGHT before I fall asleep at night so I unplug it and wait for morning...

Jessie

"There is no snooze button on a cat who wants breakfast."
OsnobunnieO is offline  
post #8 of 8 (permalink) Old 03-02-2005, 10:19 PM
 
Join Date: Oct 2004
Posts: 741
I've had mine for... about 4 months. No problems yet. Both the kitties love it.
BaileyAndSammi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cat Forum : Cat Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome